Beiträge von Mr.X

    Als Betreiber einer Community in der WoltLab Cloud können Sie sich entspannt zurücklehnen und sich voll und ganz Ihrer Community widmen. Ein Angebot, das mit Ihrer Community wächst und bei dem Sie mit uns durchgehend einen einzigen Ansprechpartner für alle Belange rund um Ihre Seite haben.


    Nach dem überzeugenden und erfolgreichen Betrieb in den vergangenen Monaten verlässt die WoltLab Cloud nun offiziell die Beta-Phase. Wir werden alles daransetzen, unseren bestehenden und neuen Kunden weiterhin das bestmögliche Nutzungserlebnis zu ermöglichen. Wir haben im Verlauf der Beta-Phase unsere angebotenen Pakete überarbeitet und die zugesicherten Ressourcen deutlich angehoben, alle bestehenden Kunden profitieren ohne Mehrkosten von den neuen Paketen – mehr Leistung zum selben Preis.


    ➡️ Informationen & Preise der WoltLab Cloud

    Die Stärken der WoltLab Cloud

    Alle WoltLab Suite Apps sind bereits inklusive.

    Keine versteckten Zusatzkosten, die regulären Lizenzkosten fallen vollständig weg. Sie erhalten automatisch den Zugang zu allen neu erscheinenden Versionen ohne Aufpreis.


    Die überzeugende Komplettlösung aus einer Hand.

    Wir übernehmen alle anfallenden technischen Arbeiten. Bei allen Fragen rund um Ihre Community stehen wir Ihnen als kompetenter Ansprechpartner zur Verfügung.


    Zuverlässigkeit und Geschwindigkeit werden bei uns großgeschrieben.

    Langsame und unzuverlässige Hosting-Angebote können selbst den begeistertsten Mitgliedern Ihrer Community die Freude rauben, lassen Sie Ihre vergangenen Mühen nicht vergebens sein.


    Hohe Datensicherheit und Datenschutz sorgen für einen ruhigen Schlaf.

    Alle Ihre Daten werden redundant und unter Einsatz verschlüsselter Verbindungen auf Servern in Deutschland gespeichert und vor unberechtigten Zugriffen geschützt. Ausgeklügelte Konzepte und Systeme sorgen für eine hohe Stabilität und schützen Sie auch vor inzwischen leider allgegenwärtigen DDoS-Angriffen.


    Installation von Erweiterungen und Stile aus dem Plugin-Store.

    Mit dem Plugin-Store steht Ihnen eine umfangreiche Quelle für von uns überprüften Erweiterungen zur Verfügung, mit der Sie die Software bestmöglich auf die Anforderungen Ihrer Community zuschneiden können.


    Quelle: Die Komplettlösung für Ihre Community – WoltLab Cloud - Neuigkeiten und Hinweise - WoltLab®


    Datum: 1. Juli 2020

    Uhrzeit: 18:54

    Wir haben soeben Updates für unsere Produkte freigegeben:

    • WoltLab Suite 5.2.7
    • WoltLab Suite 3.1.15
    • WoltLab Suite 3.0.25


    Stabilitäts- und Fehlerbehebungsversionen (auch bekannt als "minor releases"), beseitigen ausschließlich Fehler in der aktuellen Version und führen keine neuen Funktionen ein. Es wird ausdrücklich empfohlen diese Updates anzuwenden.

    Aktualisierung einer bestehenden Installation

    Öffnen Sie die Administrationsoberfläche und rufen Sie den Menüpunkt Konfiguration > Pakete > Pakete auflisten auf. Klicken Sie dann auf den Button Updates suchen, diesen finden Sie rechts oberhalb der Paketauflistung.

    Bedeutende Änderungen

    Bitte beachten Sie, dass die unten stehende Liste nur die wichtigsten Änderungen enthält. Kleinere Korrekturen (u.a. Tippfehler) werden nicht separat aufgeführt.


    WoltLab Suite Blog

    • Der Link zu den weiteren Blogs im Benutzerprofil war defekt. 3.1

    WoltLab Suite Calendar

    • Das Icon zum Teilen eines Termins verwendete das falsche Icon. 5.2

    WoltLab Suite Filebase

    • Der [file]-BBCode wird nun korrekt als Block-Element umgesetzt. 3.1 5.2

    WoltLab Suite Forum

    • Fehlerhafte Kodierung von Objekt-Namen in Bedingungen. 5.0 5.1 5.2
    • Bei der Wiederherstellung des einzigen Beitrags eines Themas wurden die Zähler nicht korrekt aktualisiert. 5.1 5.2
    • Die Einstellung für die minimale Anzahl an Buchstaben bzw. Wörtern von Themen wurden nicht korrekt berücksichtigt. 5.1 5.2
    • Externe Links sind nun von der Sitemap ausgeschlossen. 5.1 5.2
    • Fehlende Benachrichtigung für nachträglich eingefügte Zitate in Beiträgen. 5.1 5.2
    • Bei der Veröffentlichung eines Themas zum aktuellen Zeitpunkt wurden das Datum der Beiträge nicht angepasst. 5.2

    WoltLab Suite Gallery

    • Der Button zum Hochladen wird nun ausgeblendet, wenn nur die Verlinkung externer Videos gestattet ist. 3.1 5.2

    WoltLab Suite Core: Konversationen

    • Fehlende Sprachvariable im Dialog zum Bearbeiten der Betreffzeile. 3.1 5.2
    • Die redundante Kodierung von Sonderzeichen in Benutzernamen führte zu einer Abweisung bei der Prüfung der Teilnehmer. 5.2

    WoltLab Suite Core: Importer

    • WoltLab Burning Board 4.x
      • Fehlerhafte Übernahme der Typen von selbst erstellten Eingabefeldern im Benutzerprofil. 3.1 5.2

    WoltLab Suite Core: Verwarnungen

    • Die Verwarnung von Benutzern aus dem Benutzerprofil heraus funktionierte nicht korrekt. 3.1 5.2

    WoltLab Suite Core

    • Fehlerhafte Kodierung von Objekt-Namen in Bedingungen. 3.0 3.1 5.2
    • Anpassung von jQuery zum Schutz gegen CVE-2019-11358. 3.0 3.1 5.2
    • In Cronjobs verursachte Fehlermeldungen werden nun zusätzlich in das allgemeine Fehlerprotokoll übernommen. 3.1 5.2
    • Die Benachrichtigung für endende bezahlte Mitgliedschaften enthielt eine fehlerhafte Angabe zur Restlaufzeit. 3.1 5.2
    • Einige Konflikte beim Einsatz mehrere Kommentar-Elemente auf einer Seite wurden korrigiert. 3.1 5.2
    • Die Massenverarbeitung von Benutzern schlug fehl, wenn mehr als 65.000 Benutzer betroffen waren. 3.1 5.2
    • Die Kopfgrafik von Artikeln zeigte in manchen Fällen die Bildunterschrift in einer abweichenden Sprache an. 3.1 5.2
    • Fehlerhafte Erkennung des großen iPad Pro. 5.2
    • Eingebettete Dateianhänge aus führeren Versionen wurden falsch ausgewertet und führten zur Anzeige der Vorschaugrafik. 5.2
    • Erwähnte Benutzergruppen, die aus mehr als einem Leerzeichen bestehen, wurden nicht korrekt erkannt. 5.2
    • Unterdrückung der automatischen Ausfüllung von Passwörtern in Eingabefeldern in der Administrationsoberfläche. 5.2
    • Verbesserte Fehlerbehandlung bei fehlgeschlagenen SSL/TLS-Verbindungen. 5.2
    • Überarbeitung des Twitch-BBCode auf Grund einer kürzlich erfolgten API-Änderung. 5.2


    Quelle: Update: WoltLab Suite 5.2.7 / 3.1.15 / 3.0.25 - Neuigkeiten und Hinweise - WoltLab®


    Datum: 27. Juni 2020

    Uhrzeit: 22:59

    Wir haben soeben Updates für unsere Produkte freigegeben:

    • WoltLab Suite 5.2.6
    • WoltLab Suite 3.1.14


    Stabilitäts- und Fehlerbehebungsversionen (auch bekannt als "minor releases"), beseitigen ausschließlich Fehler in der aktuellen Version und führen keine neuen Funktionen ein. Es wird ausdrücklich empfohlen diese Updates anzuwenden.

    Aktualisierung einer bestehenden Installation

    Öffnen Sie die Administrationsoberfläche und rufen Sie den Menüpunkt Konfiguration > Pakete > Pakete auflisten auf. Klicken Sie dann auf den Button Updates suchen, diesen finden Sie rechts oberhalb der Paketauflistung.

    Untersuchung aktueller Vorfälle von kompromittierten Foren

    Wir stehen mit einigen Kunden in Kontakt, deren Foren kompromittiert wurden, mit dem Ziel die Zugangsdaten von Benutzern zu erbeuten. Der Angreifer hat dabei einige Dateien verändert, mit dem Ziel Passwörter bei der Eingabe im Klartext abzufangen und zusätzlich eine Hintertür (engl. "backdoor") geschaffen, um sich zu einem späteren Zeitpunkt erneut Zugriff zu verschaffen. Die jetzt veröffentlichten Updates überschreiben die modifizierten Dateien restlos mit der jeweiligen Originalfassung.


    Die erbeuteten Passwörter wurden in der dafür eigenes vom Angreifer angelegten Spalte logToken in der Datenbanktabelle wcf1_user abgelegt. Das Update entfernt diese Daten, in dem etwaig hinterlegte Werte mit der Zeichenkette compromised überschrieben werden. Bei Benutzern, die nicht betroffen sind, ist der Wert einfach leer.


    Sollten Sie Fragen dazu haben oder Hilfe benötigen, wenn Ihre Seite ebenfalls betroffen war, so wenden Sie sich bitte direkt an uns, wir helfen Ihnen gerne weiter.

    Wie hat der Angreifer Zugriff erlangt?

    Die Untersuchungen der betroffenen Seiten deuten bislang stark darauf hin, dass sich der Angreifer, mit Hilfe von zuvor anderweitig gestohlenen Zugangsdaten, direkt an die Administrationsoberfläche angemeldet hat. Wir können es nicht genug betonen: BITTE VERWENDEN SIE NICHT DIE SELBEN PASSWÖRTER AUF UNTERSCHIEDLICHEN WEBSITES! SIE GEFÄHRDEN DAMIT SICH UND IHRE COMMUNITY!

    Bedeutende Änderungen

    Bitte beachten Sie, dass die unten stehende Liste nur die wichtigsten Änderungen enthält. Kleinere Korrekturen (u.a. Tippfehler) werden nicht separat aufgeführt.


    WoltLab Suite Blog

    • Die Erkennung von Erwähnungen basierte auf einem ineffizienten API-Aufruf und arbeitet nun deutlich schneller. 3.1 5.2
    • Numerische Werte wurden beim Import nicht immer korrekt erkannt. 3.1 5.2
    • Der Button für Reaktionen wurde unabhängig von den Berechtigungen angezeigt. 5.2

    WoltLab Suite Calendar

    • Numerische Werte wurden beim Import nicht immer korrekt erkannt. 3.1 5.2
    • Einige Fremdschlüssel wurden beim Upgrade von der Version 3.1 nicht korrekt im SQL-Log eingetragen. 5.2
    • Die AMP-Version von Terminen wurde entfernt. 5.2

    WoltLab Suite Filebase

    • Beim Bearbeiten von Rezensionen wurden unbeabsichtigt Einträge im Änderungsprotokoll von Dateien angelegt. 5.2
    • Die AMP-Version von Dateien wurde entfernt. 5.2
    • Numerische Werte wurden beim Import nicht immer korrekt erkannt. 5.2

    WoltLab Suite Gallery

    • Wenn die Suche nach Bildern erfolglos war, wurde eine unpassende Fehlermeldung angezeigt. 3.1 5.2
    • Die Erkennung von Erwähnungen basierte auf einem ineffizienten API-Aufruf und arbeitet nun deutlich schneller. 3.1 5.2
    • Numerische Werte wurden beim Import nicht immer korrekt erkannt. 3.1 5.2

    WoltLab Suite Forum

    • Beim Kopieren von Foren wurde die Einstellung für private Themen nicht übernommen. 3.1 5.2
    • Die Erkennung von Erwähnungen basierte auf einem ineffizienten API-Aufruf und arbeitet nun deutlich schneller. 3.1 5.2
    • Moderatoren konnte Beiträge nicht in Foren kopieren oder verschieben, die aus der Forenliste ausgeblendet wurden. 3.1 5.2
    • Numerische Werte wurden beim Import nicht immer korrekt erkannt. 3.1 5.2
    • Beim Kopieren von Foren wurde die Einstellung für die besten Antworten nicht übernommen. 5.2
    • Die AMP-Version von Themen wurde entfernt. 5.2
    • Fehlerhafte Eingaben beim Erstellen eines Themas konnten dazu führen, dass die Eingaben des Themenformulars verloren gingen. 5.2

    WoltLab Suite Core: Conversations

    • Die Anzeige der letzten Aktivität eines Nutzers konnte indirekt unsichtbare Teilnehmer in eigenen Konversationen preisgeben. 3.1 5.2
    • Konversationsnachrichten werden nun aus Sucherergebnissen herausgehalten, wenn die Berechtigungen entzogen wurden. 3.1 5.2

    WoltLab Suite Core

    • Numerische Werte wurden beim Import nicht immer korrekt erkannt. 3.1 5.2
    • Beim Bearbeiten eines Nutzers mit Profilfoto, dass der Nutzer aber nicht sehen darf, wurde es unbeabsichtigt gelöscht. 3.1 5.2
    • Trophäen konnten unter bestimmten Umständen mehrfach vergeben werden. 3.1 5.2
    • ImageMagick-Unterstützung für die Bildverarbeitung
      • Einige Vorschaugrafiken wurden mit zu großen Abmessungen generiert. 3.1 5.2
      • Die Normalisierung von Bilddrehungen entsprechend der EXIF-Daten wurde ohne Korrektur der EXIF-Informationen durchgeführt. 3.1 5.2
      • Die Position von eingefügtem Text wurde in einigen Fällen falsch berechnet. 3.1 5.2
      • Die Schriftgröße wurde als pt interpretiert, hätte aber als px berechnet werden sollen. (Die Dokumentation auf php.net ist irreführend). 3.1 5.2
    • Beim Scrollen eines Tab-Menüs unter iOS konnte es dazu kommen, dass die Menüpunkte kurzzeitig nicht mehr reagierten. 3.1 5.2
    • Alte Einträge in der Moderation wurden unter bestimmten Umständen nicht entfernt. 3.1 5.2
    • Die Protokollierung von Suchbegriffen konnte auf Grund eines Race Condition zu einem Fehler führen. 5.2
    • Beschreibungen von Kategorien unter Verwendung von HTML wurden an einigen Stellen fehlerhaft angezeigt. 5.2
    • Die dynamische Skalierung von Bildern im Browsern arbeitete auf Grund eines Fehlers in Chrome 81 fehlerhaft. 5.2
    • Der Tooltip für Zitate ist auf mobilen Geräten nicht länger markierbar. 5.2
    • Veraltete <font>-Elemente, die durch einige Browser eingefügt werden, werden nun korrekt umgewandelt. 5.2
    • Die Interaktion mit dem Hauptmenü wurde auf übergrößen Android-Tablets verbessert. 5.2
    • Die Sortierung von Trophäen funktionierte auf mehrseitigen Auflistungen nicht korrekt. 5.2


    Quelle: Update: WoltLab Suite 5.2.6 / 3.1.14 - Neuigkeiten und Hinweise - WoltLab®


    Datum: 10. Mai 2020

    Uhrzeit: 23:14

    WoltLab Suite 3.0 erschien am 11. Januar 2017 und nach über 3 Jahren endete am 28. Februar 2020, zwei Jahre nach der Veröffentlichung des Nachfolgers WoltLab Suite 3.1, die garantierte Unterstützung dieser Version. Wir werden die Produkte der WoltLab Suite 3.0-Reihe noch für einige Zeit mit Sicherheitsupdates versorgen, bevor diese Versionen endgültig eingestellt werden.


    Betroffene Produkte

    • WoltLab Suite Forum 5.0
    • WoltLab Suite Core 3.0
    • WoltLab Suite Blog 3.0
    • WoltLab Suite Calendar 3.0
    • WoltLab Suite Filebase 3.0
    • WoltLab Suite Gallery 3.0

    1. März 2020 – 1. Etappe

    • Die reguläre Unterstützungsperiode ist abgelaufen.
    • Updates beschränken sich ausschließlich auf sicherheitsrelevante Probleme.
    • PHP 7.4 ist die Letzte noch unterstütze Version.

    1. März 2021 – 2. Etappe

    • Ablauf der beschränkten Unterstützung, es werden keine Updates mehr für diese Version veröffentlicht.
    • Der Ticket-Support für diese Version endet, Unterstützung wird nur noch für die Produkte der WoltLab Suite 3.1 oder neuer angeboten.

    1. März 2022 – 3. Etappe

    • Die Downloads dieser Version werden aus dem Kundebereich entfernt.
    • Abschaltung der zugehörigen Update-Server.
    • Entfernung der Pakete aus dem Plugin-Store.


    Quelle: Eingeschränkte Unterstützung für WoltLab Suite 3.0 - Neuigkeiten und Hinweise - WoltLab®


    Datum: 28. April 2020

    Uhrzeit: 17:09

    Wir haben soeben ein Update für das Paket "WoltLab Suite Core: Konversationen" veröffentlicht, das ein großes und ein kleineres Problem behebt.

    Missbrauch der Konversationen zur Verteilung von Spam-Nachrichten

    Wir sind in den vergangenen Tagen auf einen ausgefeilten Bot aufmerksam geworden, der gezielt auf das Konversations-System ausgerichtet ist, um diesen für Spam-Nachrichten zu missbrauchen. Der Bot arbeitet dabei in zwei Phasen um seine Effizienz zu erhöhen, im ersten Schritt wird die Mitgliederliste ausgelesen, um eine vollständige Liste der Benutzernamen zu erhalten. Anschließend werden in der zweiten Phase die zuvor abgegriffenen Benutzernamen verwendet, um jede einzelnen per Konversation mit der Werbebotschaft anzuschreiben. Darüber hinaus wurde der Bot so gestaltet, dass nach dem Versand die Konversation sofort verlassen wird, um das Limit der aktiven Konversationen zu umgehen.


    Um unsere Kunden und deren Nutzer zu schützen, haben wir eine neue Maßnahme implementiert, die einen derartigen Missbraucht verhindert und eine wirksame Verteidigung gegen vergleichbare Angriffsszenarien darstellt. Dazu haben wir in das Konversation-System der WoltLab Suite 3.0, 3.1 und 5.2 eine neue Berechtigung eingebaut, die die Anzahl der gestarteten Konversationen innerhalb eines 24-Stunden-Zeitfensters pro Benutzer begrenzt. Standardmäßig können 10 Konversationen gestartet werden, Administratoren werden standardmäßig von dieser Begrenzung befreit.


    Seitenbetreiber können die Begrenzung individuell pro Benutzergruppen konfigurieren, einschließlich dem Spezialwert -1, der die Beschränkung für die jeweilige Benutzergruppe vollständig aufhebt. Der Name der neuen Berechtigung lautet Maximale Anzahl gestarteter Konversation innerhalb von 24 Stunden.

    Zusätzlich korrigiert: Indirekte Ermittlung von unsichtbaren Teilnehmern in Konversationen

    Dieses Update korrigiert zusätzlich einen Fehler, durch den es mit Hilfe des Teilnehmer-Filters in der Liste der Konversationen möglich war, unsichtbare Teilnehmer in Konversationen aufzudecken, in dem die Liste der Konversationen mit den sichtbaren Teilnehmerlisten abgeglichen wurde. Dabei ist uns zusätzlich ein mögliches Performance-Problem im Zusammenhang mit diesem Filter aufgefallen, den wir ebenfalls korrigiert haben.


    Quelle: Update: WoltLab Suite 5.2.5 / 3.1.13 / 3.0.24 - Neuigkeiten und Hinweise - WoltLab®


    Datum: 13. April 2020

    Uhrzeit: 17:39

    Die WoltLab Cloud – Jetzt verfügbar!

    Die WoltLab Cloud ist ab sofort verfügbar, unsere belastbare und ausgeklügelte Lösung für den Betrieb Ihrer Community. Mit unserem Managed Hosting-Angebot WoltLab Cloud bieten wir eine umfassende Lösung für den Betrieb der WoltLab Suite. Wir übernehmen den gesamten technischen Betrieb, angefangen von der Installation über die kontinuierliche Aktualisierung der Software bis hin zu täglichen Datensicherungen. Alle WoltLab Suite Apps stehen unbeschränkt zur Verfügung und durch den konsequenten Einsatz von Elasticsearch profitieren Sie ohne Aufpreis von einer Suchfunktion auf Enterprise-Niveau.


    ➡️ Informationen & Preise der WoltLab Cloud

    Die Stärken der WoltLab Cloud

    Wir haben uns von Anfang an das Ziel gesetzt, eine robuste und zuverlässige Plattform zu entwickeln, die in der Lage ist, einen stabilen Betrieb und eine durchgehend hohe Geschwindigkeit zu gewährleisten.


    Die wichtigsten Merkmale der WoltLab Cloud:

    • Alle WoltLab Suite Apps sind enthalten.
      • Inklusive Elasticsearch zur präzisen und schnellen Bearbeitung von Suchanfragen.
    • Vollständige technische Betreuung der Installation.
      • Wir übernehmen die Installation und regelmäßige Aktualisierung der Software.
      • Die täglichen Datensicherungen werden verschlüsselt auf einem separaten Server abgelegt.
      • Robuster DDoS-Schutz auf Netzwerkebene durch unseren Partner Voxility.
    • Installation von Stilen und Erweiterungen aus dem WoltLab Plugin-Store.
    • Optimierte und leistungsstarke Server-Infrastruktur.
      • Alle Daten werden zu 100% auf Enterprise-SSDs gespeichert.
      • Moderne und nach unseren Anforderungen zusammengestellte Server von Hewlett Packard Enterprise mit skalierbaren Intel Xeon Gold-Prozessoren der 2. Generation.
      • Geprüftes Tier 3+-Rechenzentrum in Frankfurt am Main.
    • Vollständige SSL/TLS-Verschlüsselung mit Zertifikaten von Let’s Encrypt.
    • Die Aufschaltung einer eigenen Domain ist ohne Zusatzkosten möglich.
    • Datenschutzkonformer Betrieb gemäß DSGVO
      • Vollständige Speicherung aller Daten innerhalb Deutschlands.
      • Datenübertragung durchgängig über SSL/TLS-verschlüsselte Verbindungen.
      • Auftragsverarbeitungsvertrag (AVV)
      • Umfassende technische und organisatorische Maßnahmen zum Schutz Ihrer Daten gemäß Art. 32 DSGVO.


    Mehr Informationen haben wir im Thema Managed Hosting – Vorstellung der WoltLab Cloud zur Verfügung gestellt.


    Quelle: Managed Hosting gestartet – WoltLab Cloud - Neuigkeiten und Hinweise - WoltLab®


    Datum: 27. März 2020

    Uhrzeit: 20:34

    Wir haben soeben Updates für unsere Produkte freigegeben:

    • WoltLab Suite 5.2.4


    Stabilitäts- und Fehlerbehebungsversionen (auch bekannt als "minor releases"), beseitigen ausschließlich Fehler in der aktuellen Version und führen keine neuen Funktionen ein. Es wird ausdrücklich empfohlen diese Updates anzuwenden.

    E-Mail-Versand von Benutzern an andere Benutzer

    Im Standardumfang gibt es eine historisch entstandene Funktion, mit der Benutzer (und je nach Konfiguration auch Gäste) andere Benutzer über ein Formular per E-Mail anschreiben können. Diese Funktion hat in der heutigen Zeit keine fundamentale Bedeutung, wird aber bei der Konfiguration, insbesondere bei Migrationen, leicht übersehen. Das Formular basiert auf den Benutzergruppenrechten, die in früheren Versionen die Nutzung standardmäßig erlaubt haben und schlicht nie umkonfiguriert wurden.


    Leider mussten wir feststellen, dass diese Funktion inzwischen für den Spam-Versand missbraucht wird und darüber teils enorme E-Mail-Mengen generiert werden. Wir haben uns daher entschlossen, zwei sofortige Maßnahmen einzuleiten, um das Problem zu entschärfen:

    1. Die Benutzergruppenrechte für diese Funktion werden einmalig für alle Gruppen entzogen. Administratoren können die Funktion nach eigenen Ermessen anschließend wieder reaktivieren, auch wenn wir vom Einsatz ausdrücklich abraten müssen.
    2. Der Captcha-Schutz des Formulars wirkte sich zuvor nur auf Gäste aus, er wird nun ebenfalls für Benutzer angewendet. Dies ist dadurch das erste Formular, dass einen Captcha-Schutz auch für angemeldete Benutzer erfordert.

    Für Entwickler: Anpassung des HTML-Aufbaus für .contentItemLink

    Die neue .contentItemList wurde als allgemein verwendbare Lösung für Inhalte mit Teaser-Bildern entwickelt. Der HTML-Aufbau wies allerdings eine Designschwäche auf, die ein Link-Element rund um den Inhaltsbereich vorsah und leicht zu Kollisionen mit diversen Inhaltstypen führte.

    HTML

    Code

    <a href="…" class="contentItemLink">

    <!-- Inhalt -->

    </a>

    Sollte geändert werden in:

    HTML

    Code

    <div class="contentItemLink">

    <!-- Inhalt -->

    <a href="…" class="contentItemLinkShadow"></a>

    </div>

    Am CSS ändert sich nichts relevantes, so dass die Darstellung auch mit dem alten HTML-Aufbau gewahrt bleibt. Die gesamte Änderung ist vollständig abwärtskompatibel zur bisherigen Lösung, wir empfehlen dennoch ausdrücklich die Migration auf den neuen Aufbau.


    Deprecate the use of `<a>` for `.contentItemLink` · Issue #3189 · WoltLab/WCF · GitHub

    Aktualisierung einer bestehenden Installation

    Öffnen Sie die Administrationsoberfläche und rufen Sie den Menüpunkt Konfiguration > Pakete > Pakete auflisten auf. Klicken Sie dann auf den Button Updates suchen, diesen finden Sie rechts oberhalb der Paketauflistung.

    Bedeutende Änderungen

    Bitte beachten Sie, dass die unten stehende Liste nur die wichtigsten Änderungen enthält. Kleinere Korrekturen (u.a. Tippfehler) werden nicht separat aufgeführt.

    WoltLab Suite Blog

    • Das für die Artikel-Vorschau erzeugte HTML war ungültig und führte zu stellenweise unklickbaren Bereichen. 5.2
    • Für Suchmaschinen ausgeschlossene Seiten wurden irrtümlich in die Sitemap aufgenommen 5.2
    • Die Liste der Artikel mit einem spezifischen Tag unterstützte keine zusätzlichen Ergebnisseiten. 5.2
    • Neues Template-Event in der Kopfzeile von Artikeln. 5.2

    WoltLab Suite Calendar

    • Für Suchmaschinen ausgeschlossene Seiten wurden irrtümlich in die Sitemap aufgenommen 5.2
    • Die Liste der Termine mit einem spezifischen Tag unterstützte keine zusätzlichen Ergebnisseiten. 5.2

    WoltLab Suite Filebase

    • Individuelle Eingabefelder vom Typ "boolean" konnten auf Grund einer Kollision mit einer HTML-ID nicht ausgewählt werden. 5.2
    • Für Suchmaschinen ausgeschlossene Seiten wurden irrtümlich in die Sitemap aufgenommen 5.2
    • Die Liste der Dateien mit einem spezifischen Tag unterstützte keine zusätzlichen Ergebnisseiten. 5.2

    WoltLab Suite Gallery

    • Die Liste der gelöschten Bilder erzeugte einen Fehler beim Aufruf durch einen Gast. 5.2
    • Für Suchmaschinen ausgeschlossene Seiten wurden irrtümlich in die Sitemap aufgenommen 5.2
    • Die Liste der Alben bzw. Bilder mit einem spezifischen Tag unterstützte keine zusätzlichen Ergebnisseiten. 5.2

    WoltLab Suite Forum

    • Die Verschiebung eines Thema unter PHP 7.4 führte zu einem Fehler. 5.2
    • Leere Themen wurden beim Aufruf in der AMP-Ansicht fehlerhaft verarbeitet. 5.2
    • Die Liste der Themen mit einem spezifischen Tag unterstützte keine zusätzlichen Ergebnisseiten. 5.2

    WoltLab Suite Core: Conversations

    • Ein Fehler wurde korrigiert, der beim Antworten auf eine Konversation mit einem oder mehreren gelöschten Teilnehmern auftrat. 5.2

    WoltLab Suite Core: Importers

    • XenForo 2.x
      • Unterstützung für Pixel-basierte Schriftgrößen und das rgb()-Format für die Schriftfarbe. 5.2
      • Unterstützung für zusätzliche Metadaten bei eingebetteten Dateianhängen. 5.2
    • WoltLab Suite 3.x, 5.x
      • Fehlerhafte Erkennung von Kategorien beim Import von Medien. 5.2

    WoltLab Suite Core

    • Zwei Kompatibilitätsprobleme unter PHP 7.4 wurden korrigiert. 5.2
    • Ein neues Template-Event wurde in der Seitenleiste für Nachrichten im Bereich der Rang-Anzeige eingefügt. 5.2
    • Das Formular zum Anlegen von eigenen Sprachvariablen schlug manchmal bei der Prüfung der ausgewählten Kategorie fehl. 5.2
    • Irrtümliche Auswahl von mehrsprachigen Artikeln bei dem Aufruf aus der Kategorieliste. 5.2
    • Eine Kollision des mobilen Interface auf Bildschirmen zwischen 768 und 1024 Pixel wurde behoben. 5.2
    • Die Benutzung des Hauptmenü auf übergroßen Tablets (über 1024 Pixel Bildschirmbreite) wurde verbessert. 5.2
    • Die Darstellung von Code-Boxen in der AMP-Ansicht wurde verbessert. 5.2
    • Das für die Artikel-Vorschau erzeugte HTML war ungültig und führte zu stellenweise unklickbaren Bereichen. 5.2


    Quelle: Update: WoltLab Suite 5.2.4 - Neuigkeiten und Hinweise - WoltLab®


    Datum: 26. März 2020

    Uhrzeit: 23:39

    Paket-Servern von Drittanbietern im Rahmen von (optionalen) Paketen

    In den vergangenen Jahren konnten wir eine steigende Anzahl an Problemen in Kombination mit Paket-Servern von Dritten beobachten, beschränkt auf Pakete, die im Plugin-Store angeboten werden.


    Im Interesse unserer Kunden haben wir uns dazu entschlossen, ab sofort keine neuen Pakete oder Updates mehr freizuschalten, die direkt oder indirekt (etwa über optionale Pakete) die Installation von Paket-Servern von Drittanbietern vornehmen. Dies betrifft ausdrücklich nur Pakete im Plugin-Store, technisch erfolgt keine Änderung im Core, es ist weiterhin möglich, Paket-Server über Pakete von Drittseiten bzw. manuell anzulegen.


    Wir möchten dabei im Sinne der Transparenz die wichtigsten Gründe für unsere Entscheidung nachfolgend darlegen.

    Fehlende Notwendigkeit bei Produkten aus dem Plugin-Store

    Für Erweiterungen und Stile aus dem Plugin-Store besteht keine Notwendigkeit zur Installation von Paket-Servern von Drittanbietern, denn alle Updates werden, sobald diese geprüft wurden, direkt vom Plugin-Store ausgeliefert.

    Auslieferung von ungeprüften Updates

    Einige Drittanbieter geben Updates für Pakete bei Verfügbarkeit direkt frei und warten die Prüfung im Plugin-Store nicht ab. Dies ist problematisch, da die abschließende Prüfung jedes neuen Paketes und jedes Updates manuell durch einen Mitarbeiter der WoltLab GmbH erfolgt.


    Im Durchschnitt wird jedes Dritte Update auf Grund von relevanten Mängeln im ersten Anlauf abgelehnt. Die vorzeitige Auslieferung über Paket-Server von Drittanbietern unterläuft diese Prüfung, die der Vermeidung von Sicherheits- und Stabilitätsproblemen dient.

    Kollision mit kommerziell angebotenen Produkten

    Ein Sonderfall stellt die vorzeitige Freigabe von Updates dar, bei dem das Produkt sowohl im Plugin-Store als auch vom Dritthersteller direkt angeboten wird. Dies kann zu Konflikten führen, wenn für den Paket-Server des Drittanbieters keine Zugangsdaten hinterlegt wurden und somit Updates angeboten werden, bevor diese im Plugin-Store verfügbar sind.

    Sicherheitsbedenken bei ungeprüften Paketen und Updates

    Die Stärke des Paket-Systems ist gleichzeitig einer der größten Schwachstellen, denn Erweiterungen können nahezu beliebige Änderungen durchführen, bis hin zur Ausführung von sicherheitskritischem Schadcode. Dies wird dadurch erschwert, dass Paket-Server für nahezu beliebige Pakete Updates zum Download anbieten können, die einzige Ausnahme stellen unsere Produkte dar, die ausschließlich über die offiziellen Paket-Server ausgeliefert werden können.


    Leider Häufen sich Vorfälle, in denen die Websites von Drittanbietern zum Ziel von Angriffen werden, dabei gab es sowohl Übernahmen auf DNS-Ebene, d.h. die Domains zeigten auf einen fremden Server, als auch die direkte Kompromittierung der Server-Systeme. Dies bedeutet auch, dass ein Angreifer dadurch die Kontrolle über die Paket-Server dieser Anbieter erhält und diese missbrauchen kann, um Schadcode nahezu unbemerkt ausliefern zu können. Ein Blick über den Tellerrand verrät, dass dies keinesfalls ein fiktives Szenario ist, sondern beispielsweise bei NPM oder diversen Linux-Distributionen immer wieder versucht wird oftmals nur durch hohen Schutzaufwand verhindert werden konnten.

    Kompatibilität mit der WoltLab Cloud

    Wir werden in Kürze damit beginnen, Erweiterungen und Stile im Plugin-Store auf die Kompatibilität mit der WoltLab Cloud zu prüfen. Einträge, die diese Prüfung bestehen, werden von uns mit einer Markierung versehen, eine Art „Negativ-Markierung“ ist aktuell nicht vorgesehen.


    Die Kriterien für die Ermittlung der Kompatibilität lauten wie folgt:

    • Kompatibilität mit der WoltLab Suite 5.2.
    • Ausgehende HTTP(S)-Verbindungen laufen konsequent über die HTTPRequest-Klasse oder berücksichtigen die Proxy-Konfiguration korrekt.
    • Keine ausgehenden Verbindungen zu abweichenden TCP- oder UDP-Ports.
    • Kein Massenversand von E-Mails.
    • Keine Überschneidung mit Privilegien die im Rahmen eines Managed Betriebs unter Vorbehalt stehen, beispielsweise eine direkte Datenbankverwaltung.
    • Pakete, die Paket-Server von Drittanbietern installieren, sind grundsätzlich ausgeschlossen.

    Diese Kriterien werden von der großen Masse an Paketen bereits erfüllt, daher sind keine signifikanten Einschränkungen zu erwarten.


    Quelle: Plugin-Store Richtlinien und Kompatibilität mit der WoltLab Cloud - Neuigkeiten und Hinweise - WoltLab®


    Datum: 11. März 2020

    Uhrzeit: 16:54

    Wir haben soeben Updates für unsere Produkte freigegeben:

    • WoltLab Suite 5.2.3
    • WoltLab Suite 3.1.12
    • WoltLab Suite 3.0.23


    Stabilitäts- und Fehlerbehebungsversionen (auch bekannt als "minor releases"), beseitigen ausschließlich Fehler in der aktuellen Version und führen keine neuen Funktionen ein. Es wird ausdrücklich empfohlen diese Updates anzuwenden.

    Aktualisierung einer bestehenden Installation

    Öffnen Sie die Administrationsoberfläche und rufen Sie den Menüpunkt Konfiguration > Pakete > Pakete auflisten auf. Klicken Sie dann auf den Button Updates suchen, diesen finden Sie rechts oberhalb der Paketauflistung.

    Kompatibilität mit PHP 7.4

    Die WoltLab Suite 3.0.x- und 3.1.x-Reihen erhalten im Rahmen dieses Updates notwendige Anpassungen zur Kompatibilität mit PHP 7.4.

    Bedeutende Änderungen

    Bitte beachten Sie, dass die unten stehende Liste nur die wichtigsten Änderungen enthält. Kleinere Korrekturen (u.a. Tippfehler) werden nicht separat aufgeführt. Einige Änderungen wurden bereits mit früheren Updates für die Version 3.1 bzw. 5.2 ausgeliefert und werden nicht gesondert erwähnt.

    WoltLab Suite Blog

    • Kompatibilität mit PHP 7.4. 3.1 3.0
    • Eine fehlerhafte Kodierung von Werten führt zu ungültigen Daten für die erweiterten Suchergebnisse. 3.1

    WoltLab Suite Calendar

    • Beim Import von Terminen im iCal-Format wird im Falle fehlender Koordinaten alternativ auf die Ortsangabe zurückgegriffen. 5.2
    • Das Enddatum eines Termins konnte manchmal nicht bearbeitet werden. 3.1 3.0
    • Der Maximalwert für die Wiederholung von Terminen wurde deutlich angehoben. 3.0
    • Termine mit ungültigen Zeitangaben werden beim Import im iCal-Format nun übersprungen. 3.0

    WoltLab Suite Filebase

    • Bei eigenen Ja-/Nein-Feldern wurde die getätigte Auswahl nicht dargestellt, wenn diese "Nein" lautet. 5.2

    WoltLab Suite Gallery

    • Das erzeugte HTML der BBCodes für Alben bzw. Bilder erzeugte manchmal unpassendes HTML. 5.2
    • Wasserzeichen wurden irrtümlich auf Vorschaugrafiken von Videolinks aufgebracht. 3.1
    • Die Positionsangabe innerhalb von verschachtelten Kategorien war falsch. 3.1 3.0
    • Im Album-BBCode wurde eine falsche Anzahl an Bildern ausgewiesen. 3.1 3.0

    WoltLab Suite Forum

    • Leere RSS-Feeds konnten zu einer Fehlermeldung führen. 5.2
    • Der Reaktionen-Button auf mobilen Endgeräten wurde auf Grund mehrerer Kompatibilitätsprobleme in das Nachrichtenmenü zurückgeschoben. 5.2
    • Themen konnten aus Auflistungen verschwinden, wenn der Startbeitrag einem Gast zugeordnet ist und der aktive Benutzer andere Benutzer blockiert hat. 5.2
    • Bei eigenen Ja-/Nein-Feldern wurde die getätigte Auswahl nicht dargestellt, wenn diese "Nein" lautet. 5.2
    • Die Liste der unerledigten Themen führte bei Gästen zu ungenauen Ergebnissen. 3.1
    • Beim Löschen von Beiträgen wurden fehlerhafte Einträge im Änderungsprotokoll erzeugt. 3.0
    • Foren vom Typ "Externer Link" konnten zu einem Fehler bei der Bearbeitung von Gruppenrechten führen. 3.0

    WoltLab Suite Core: Conversations

    • Bei der Zusammenfügung von Benutzern wurde der Benutzername in der Teilnehmerliste nicht aktualisiert. 3.0
    • Das Verlassen einer Konversation, die noch im Entwurfstadium ist, führte zu einem Fehler. 5.2 3.1 3.0

    WoltLab Suite Core: Importers

    • SMF 2.x
      • Unterstützung für Dateianhänge aus führeren Versionen. 3.0
    • MyBB 1.x
      • Fehlerhafte Erkennung von Anführungszeichen innerhalb von [font]. 3.1 3.0
    • vBulletin 5.x
      • Unterstützung zusätzlicher Variationen von [attach]. 3.1
      • BBCodes in Signaturen wurden nicht korrekt umgewandelt.
      • Die Unterstützung für Pixel-basierte Schriftgrade wurden verbessert.

    WoltLab Suite Core

    • Verbesserte Kompatibilität mit Erweiterungen die auf veralteten Komponenten zur Verarbeitung von Texten basieren. 5.2
    • Die Systemprüfung umfasst nun die verfügbaren PHP-Bibliotheken zur Verarbeitung von Grafiken. 5.2
    • Die Darstellung von Nachrichten in der Google AMP-Ansicht wurde verbessert. 5.2
    • Der Versuch einen leeren Editors in iOS Safari zu löschen, erzeugte unerwartetes HTML. 5.2
    • Die Anzahl der neuen Benachrichtigungen bzw. die Anzeige im Favicon wurde manchmal nicht aktualisiert, wenn der Browser-Tab im Hintergrund ausgeführt wird. 5.2
    • Bei der Erwähnung einer Benutzergruppe wurde nur eine Benachrichtigung erzeugt. 5.2
    • Die Verwendung der Reaktionen auf großen Touch-Geräten (iPad Pro 12.9") wurde verbessert. 5.2
    • Ein Fehler bei der Auflösung verschachtelter Listen im Editor in Chromium-basierten Browsern wurde korrigiert. 5.2
    • Das Upgrade von 3.1 auf 5.2 schlug in MySQL >= 8.0.19 fehl. 5.2
    • Das Hinzufügen bzw. Bearbeiten von Benutzern konnte stillschweigend auf Grund von Problemen mit der Signatur fehlschlagen. 3.1
    • Die Umwandlung von Textzeilen in Code innerhalb des Editors führte in Firefox zu zusätzlichen Leerzeilen. 3.1
    • Erwähnungen enthielten unsichtbare Leerzeichen am Ende und führten dadurch zu ungewollten Abständen zum nachfolgenden Text. 3.1
    • Kompatibilität mit PHP 7.4. 3.1 3.0
    • Der Facebook-Login fragt nicht länger einige veraltete Scopes ab. 3.0
    • Die GitHub-Authentifizierung wurde angepasst, um den Anforderungen der neuen API zu entsprechen. 3.1 3.0
    • Größenänderungen des Browserfensters führten nicht zu einer Neupositionierung von Dialogen. 3.0
    • Die Aktualisierung von Benutzern erzeugte Probleme mit den Signaturen neu registrierter Benutzer. 3.0
    • Access-Tokens von gesperrten Benutzern werden nun konsequent abgewiesen. 3.1 3.0
    • Die Tabs im Benutzerprofil enthielten doppelt kodierte HTML-Entities. 3.1 3.0
    • Fehlerprotokolle wurden auf Grund eines falschen Datumsvergleiches teilweise erst verzögert gelöscht. 5.2 3.1 3.0


    Quelle: Update: WoltLab Suite 5.2.3 / 3.1.12 / 3.0.23 - Neuigkeiten und Hinweise - WoltLab®


    Datum: 24. Februar 2020

    Uhrzeit: 19:14

    Wir bereits im Rahmen der WoltLab Suite 5.2 angesprochen, verfolgen wir das Ziel von kürzeren Abständen zwischen neuen Versionen und passen in dem Zusammenhang die Verwendung von Branches in unseren Repositories an. Die im Folgenden angesprochenen Änderungen werden am Mittwoch, den 19. Februar 2020, umgesetzt, es wird dringend empfohlen, ggf. bestehende Build-Tools an die Änderungen anzupassen.

    Das neue Branch-Schema

    Ältere Versionsstränge wurden bereits in der Vergangenheit in Versions-Branches, beispielsweise 2.1 oder 3.0, geführt. Im Falle der aktuellen bzw. nächsten Version kam es immer wieder mal zu Inkonsistenzen, bzw. unklaren Regeln nach denen Versionen in einen anderen Branch überführt wurden. In der Folge kam es in der Vergangenheit auch zu Missverständnissen bei Drittentwicklern, welche Funktion hinter bestimmten Branches steckten, bzw. in welchem Branch Änderungen einzupflegen sind.


    Das neue Schema folgt einigen einfachen Regeln:

    • Stabile Versionen werden ausschließlich in Versions-Branches geführt, unabhängig von ihrem Alter.
    • master ist zu jedem Zeitpunkt der Entwicklungsbranch und mündet schlußendlich in der nächsten stabilen Version.
    • Sobald die stabile .0-Version erreicht wird, übertragen wir den Stand des master in den dazu passenden Versions-Branch.
    • Der next-Branch wird obsole, an dessen Stelle verwenden wir zukünftig ausschließlich den master-Branch.

    Auswirkungen der Änderungen: Beispiel

    Das Repository des Core (GitHub - WoltLab/WCF: WoltLab Suite Core (previously WoltLab Community Framework)) dient als Beispiel für die sich daraus ergebenen Änderungen:


    Tree Vorher Nachher
    Version 2.1.x 2.1 2.1
    Version 3.0.x 3.0 3.0
    Version 3.1.x master 3.1
    Version 5.2.x next 5.2
    (Nächste Version) --- master

    Zeitplan

    Diese Änderungen treten am Mittwoch, den 19. Februar 2020, in Kraft.


    Quelle: Für Entwickler: Anpassungen an unseren öffentlichen Repositories - Neuigkeiten und Hinweise - WoltLab®


    Datum: 16. Februar 2020

    Uhrzeit: 21:19

    Der Server auf dem die Demos laufen wird morgen, den 13. Februar 2020, zwischen 13:00 Uhr und 16:00 Uhr MEZ auf Grund von Wartungsarbeiten nicht zur Verfügung stehen. In diesem Zeitraum können bestehende Demos nicht aufgerufen werden.


    Anforderungen für neue Demos werden in eine Warteschlange eingereiht und erst nach dem Abschluss der Arbeiten angelegt.


    Update 15:15 Uhr: Die Wartungsarbeiten wurden erfolgreich abgeschlossen.


    Quelle: Wartungsarbeiten am Demo-System (13. Februar 2020) - Neuigkeiten und Hinweise - WoltLab®


    Datum: 12. Februar 2020

    Uhrzeit: 18:59

    Wir haben soeben Updates für unsere Produkte freigegeben:

    • WoltLab Suite 5.2.2


    Stabilitäts- und Fehlerbehebungsversionen (auch bekannt als "minor releases"), beseitigen ausschließlich Fehler in der aktuellen Version und führen keine neuen Funktionen ein. Es wird ausdrücklich empfohlen diese Updates anzuwenden.

    Aktualisierung einer bestehenden Installation

    Öffnen Sie die Administrationsoberfläche und rufen Sie den Menüpunkt Konfiguration > Pakete > Pakete auflisten auf. Klicken Sie dann auf den Button Updates suchen, diesen finden Sie rechts oberhalb der Paketauflistung.

    Bedeutende Änderungen

    Bitte beachten Sie, dass die unten stehende Liste nur die wichtigsten Änderungen enthält. Kleinere Korrekturen (u.a. Tippfehler) werden nicht separat aufgeführt.


    WoltLab Suite Blog

    • Das für die Artikel-Vorschau erzeugte HTML war ungültig und führte zu stellenweise unklickbaren Bereichen.

    WoltLab Suite Calendar

    • Die eingebetteten HTML5-Metadaten wurden entsprechend der aktuellen Vorgaben angepasst.
    • Der Test für sich zeitlich überschneidende Termine schlug fehl, wenn das Start- und Enddatum identisch war.

    WoltLab Suite Filebase

    • Änderungen am Text von selbst angelegten Lizenzen wurden nicht übernommen.
    • Unterstützung für den Import von Rezensionen.

    WoltLab Suite Filebase: Support Threads

    • Die Themen wurden versehentlich doppelt erzeugt.

    WoltLab Suite Gallery

    • Der Kategoriefilter auf der Albumliste arbeitete nicht korrekt.
    • Im album-BBCode wurde ein falscher Wert für die Anzahl der enthaltenen Bilder angezeigt.

    WoltLab Suite Forum

    • Leere Themen führten auf Grund fehlerhafter Objekt-Zugriffe zu einer Fehlermeldung.
    • Beim Freischalten von Themen wurden diese doppelt gezählt. Es wird empfohlen, die Foren über "Anzeigen aktualisieren" entsprechend zu aktualisieren.
    • RSS-Feeds die nach Anwendung der Filter keine Inhalte mehr enthalten, führen nicht länger zu einer Fehlermeldung.
    • Die Liste der Antworten unterhalb eines Themas verwenden nun die selbe Reihenfolge wie auch im Thema selbst.

    WoltLab Suite Core: Conversations

    • Die Aktion ConversationAction::markAsRead() verwendet nicht länger implizit den aktuellen Nutzer.

    WoltLab Suite Core: Importers

    • MyBB 1.x
      • Fehlerhafte Erkennung von Anführungszeichen innerhalb von font-BBCodes.
    • vBulletin 5.x
      • Unterstützung zusätzlicher Variationen von [attach].
      • BBCodes in Signaturen wurden nicht korrekt umgewandelt.
      • Die Unterstützung für Pixel-basierte Schriftgrade wurden verbessert.
    • XenForo 2.x
      • Die Erkennung von JSON-kodierten Daten war fehlerhaft.

    WoltLab Suite Core: Infractions

    • Das Formular für Verwarnungen zeigt nun den vordefinierten Verwarnungsgrund an.

    WoltLab Suite Core

    • Besondere Trophäen wurden unter bestimmten Bedingungen doppelt vergeben.
    • Die Systemprüfung funktionierte auf Grund einem fehlerhaftem Stringvergleich bei MySQL nicht korrekt.
    • Beim Anlegen neuer Artikel im Frontend wird nicht länger ein mehrsprachiger Artikel angeboten, wenn es nur eine verfügbare Sprache gibt.
    • Die Erkennung von WebP-Grafiken schlug unter PHP 7.0 fehl.
    • Robustere Validierung für Seiten die auf Zugriffstoken basieren.
    • Die Tabs im Benutzerprofil enthielten doppelt kodierte HTML-Entities.
    • Versteckte Dialoge mit einem iframe reagierten teilweise auf Mausklicks.
    • Der Dreifachklick in Tabellenzellen im Editor führt nicht länger zu einem ungültigen HTML, wenn die Textauswahl ersetzt wird.
    • Optionale Auswahlfelder im Kontaktformular boten die neutrale Option "(Keine Auswahl)" nicht an.
    • Die DateFormField-Komponente wurde angepasst und bietet nun eine bessere Validierung und eine konsistente Verwendung von UTC-Datumsangaben.
    • Ein Kompatibilitätsproblem im Net_IDNA2-Paket unter PHP 7.4 wurde behoben.
    • Beim Upgrade von der WoltLab Suite 3.1 wurden auf einigen Seiten irrtümlich die individuelle Box-Positionierung verworfen.
    • Die Auswahl der Reaktionen wurde manchmal durch die Kopfzeile dargestellt.
    • Die Vollbildansicht des Editors funktionierte in einigen Fällen nicht korrekt.
    • Der Bearbeiten-Button in der Benutzerliste wird nun deaktiviert, wenn der aktive Benutzer keine ausreichenden Berechtigungen hat.
    • Erkennung von fehlerhaft konfigurierten PHP-Installationen, bei denen der Opcache aktiv ist, aber die Funktionen zum Zurücksetzen des Cache deaktiviert wurden.
    • Die GitHub-Authentifizierung wurde angepasst, um den Anforderungen der neuen API zu entsprechen.


    Quelle: Update: WoltLab Suite 5.2.2 - Neuigkeiten und Hinweise - WoltLab®


    Datum: 6. Februar 2020

    Uhrzeit: 20:59

    Wir haben soeben Updates für unsere Produkte freigegeben:

    • WoltLab Suite 5.2.1


    Stabilitäts- und Fehlerbehebungsversionen (auch bekannt als "minor releases"), beseitigen ausschließlich Fehler in der aktuellen Version und führen keine neuen Funktionen ein. Es wird ausdrücklich empfohlen diese Updates anzuwenden.

    Aktualisierung einer bestehenden Installation

    Öffnen Sie die Administrationsoberfläche und rufen Sie den Menüpunkt Konfiguration > Pakete > Pakete auflisten auf. Klicken Sie dann auf den Button Updates suchen, diesen finden Sie rechts oberhalb der Paketauflistung.

    Bedeutende Änderungen

    Bitte beachten Sie, dass die unten stehende Liste nur die wichtigsten Änderungen enthält. Kleinere Korrekturen (u.a. Tippfehler) werden nicht separat aufgeführt.

    WoltLab Suite Blog

    • Bei der Suche nach Inhalten auf Basis eines oder mehrerer Tags konnte es unter gewissen Umständen zu einem Fehler kommen.

    WoltLab Suite Calendar

    • Die Liste von Events eines Nutzers erzeugte eine Exception wenn keine Benutzer-ID übermittelt wurde.
    • Die Jahresansicht zeigte standardmäßig nicht das aktuelle Jahr an, dies wurde korrigiert.
    • Ungültige Datumsbereiche führen nicht länger zu einem Fehler bei der Prüfung auf Terminüberschneidungen.
    • Terminwiederholungen wurden auf Grund eines Berechnungsfehlers beim Endzeitpunkt nicht korrekt erzeugt.
    • Bei der Suche nach Inhalten auf Basis eines oder mehrerer Tags konnte es unter gewissen Umständen zu einem Fehler kommen.

    WoltLab Suite Filebase

    • Käufern einer Datei wurde eine falsche Anzahl angezeigt.
    • Bei der Freischaltung einer Datei wurde irrtümlich versucht einen nicht existierenden Eintrag aus der Moderation zu entfernen.
    • Die Aktualisierung der Anzeigen von Dateien und Versionen schlug auf Grund eines offenen Query Cursors fehl.
    • Bei der Suche nach Inhalten auf Basis eines oder mehrerer Tags konnte es unter gewissen Umständen zu einem Fehler kommen.

    WoltLab Suite Gallery

    • Innerhalb von Alben wurde das neue Layout nicht korrekt angewandt.
    • Bei der Suche nach Inhalten auf Basis eines oder mehrerer Tags konnte es unter gewissen Umständen zu einem Fehler kommen.

    WoltLab Suite Forum

    • Die Unterbindung von Dateianhängen führten zu einem irrtümlichen Fehler bei der Validierung neuer Beiträge.
    • Bei der Suche nach Inhalten auf Basis eines oder mehrerer Tags konnte es unter gewissen Umständen zu einem Fehler kommen.

    WoltLab Suite Core

    • Ein implizites Limit führte zu einer ungewollten Kürzung der Auflistung der Reaktionen.
    • Die automatische Linkerkennung und -umwandlung arbeitete fehlerhaft und führte zu einem Fehler.
    • Bildunterschriften für Medien die als Artikelbild verwendet wurden, unterstützten irrtümlich kein HTML.
    • Die Teaserbilder von Artikeln werden nun korrekt auf der Artikelliste verwendet.
    • Ein ungewollter Freiraum nach der Erwähnung von Benutzern wurde entfernt.
    • Der Upgrade-Prozess von WoltLab Suite 3.1 wurde verbessert, alle Schritte beim Upgrade des Core sind nun idempotent.
    • Die Besitzer-Gruppe hat nun zu jedem Zeitpunkt den Zugriff auf ausnahmslos alle Benutzergruppen.
    • In MySQL 8 gibt es einen Fehler, durch den die Informationen zu bestehenden Indizes verfälscht werden. Nur für MySQL 8 erfordern wir nun MySQL 8.0.14 oder neuer.
    • Bei der Suche nach Inhalten auf Basis eines oder mehrerer Tags konnte es unter gewissen Umständen zu einem Fehler kommen.


    Quelle: Update: WoltLab Suite 5.2.1 - Neuigkeiten und Hinweise - WoltLab®


    Datum: 9. Januar 2020

    Uhrzeit: 22:14

    Die unten stehende Anleitung umfasst ausschließlich ein Upgrade ausgehend von der WoltLab Suite 3.1.x. Sollten Sie ein Upgrade von einer früheren Version durchführen wollen, so beachten Sie bitte die bereitgestellten Anleitungen im Hilfe-Bereich.

    Schritt 1: Wartungsmodus aktivieren

    Der Wartungsmodus schaltet das Forum sowie alle damit zusammenhängenden Funktionen (u.a. Cronjobs) temporär ab um die Konsistenz der Daten zu gewährleisten. Jeder kurzfristige Ausfall des Forums ist unangenehm, dennoch sollten Sie diesen Schritt begehen um ein reibungsloses Upgrade zu gewährleisten, andernfalls nehmen Sie das Risiko von Inkonsistenzen bis hin zu Fehlern während des Upgrade-Vorgangs in Kauf.

    Schritt 2: Sicherung der Daten anfertigen

    Sie sollten vor jedem Update eine vollständige Sicherung der Daten des Forums durchführen und insbesondere bei einem Upgrade. Dieser Vorgang ist weitaus komplexer und zu dem auch vollständig irrevesibel, ein Fehler während des Upgrade-Vorganges kann Ihr Forum irreparabel beschädigen und somit unbrauchbar machen. Mit einer aktuellen Datensicherung können Sie das Forum in kürzester Zeit wieder auf den Zustand vor dem Upgrade zurücksetzen und den Vorgang ggf. wiederholen.


    Eine vollständige Sicherung besteht aus zwei Komponenten:

    1. Vollständige Sicherung der Datenbank
      Wir empfehlen die Nutzung von mysqldump (sollten Sie Zugriff auf die Kommandozeile haben) oder alternativ auf die kostenlose Software PhpMyAdmin.
    2. Vollständige Sicherung der Dateien
      Erstellen Sie eine Sicherung aller Dateien die zum Forum gehören, inklusive der durch Benutzer erzeugten Daten, beispielsweise Dateianhänge

    Vermeiden Sie die Nutzung von unterschiedlich alten Sicherungen von Datenbank und Dateien, inkonsistente Sicherungen führen zu Problemen und können Ihr Forum beschädigen.

    Schritt 3: (Optional) Laufzeitbegrenzungen anpassen

    Im Laufe des Upgrade-Prozesses werden diverse Änderungen an wichtigen Datenbank-Tabellen vorgenommen, allen voran Tabellen in denen Nachrichten-Texte vorgehalten werden, etwa Beiträge oder Konversationen. Abhängig von der Größe Ihres Forums kann dieser Vorgang relativ lange dauern und ein Timeout (Zeitüberschreitung) würde diesen Prozess unterbrechen und die Installation irreparabel beschädigen. Bitte passen Sie nach Möglichkeit die Begrenzungen entsprechend Ihrer Website an.


    Schritt 4: Update auf die aktuellste Version

    Bitte führen Sie vorab ein vollständiges Update durch, rufen Sie dazu ACP > System > Pakete > Pakete auflisten auf und klicken Sie auf den Button Updates suchen und lassen Sie alle verfügbaren Updates installieren.


    Schritt 5: Neue Update-Server hinzufügen

    1. Rufen Sie ACP > System > Pakete > Update-Server auflisten auf
    2. Klicken Sie auf den Button Server hinzufügen
    3. Fügen Sie http://update.woltlab.com/2019/ in das Feld Adresse ein und lassen Sie alle anderen Felder leer
    4. Klicken Sie auf den Button Absenden um den Server hinzuzufügen
    5. Fügen Sie http://store.woltlab.com/2019/ in das Feld Adresse ein und lassen Sie alle anderen Felder leer
    6. Klicken Sie auf den Button Absenden um den Server hinzuzufügen

    Schritt 6: Upgrade durchführen

    Rufen Sie bitte ACP > System > Pakete > Pakete auflisten auf und klicken Sie auf den Button Updates suchen. Im folgenden sollten Sie auf eine neue Seite weitergeleitet werden, auf der Ihnen WoltLab Suite 3 und ggf. andere Pakete zum Update angeboten werden.

    Schritt 7: Alle Anzeigen aktualisieren

    Einige der Neuerungen und Änderungen erfordern es initial sämtliche Anzeigen zu aktualisieren, bitte rufen Sie dazu ACP > Verwaltung > Anzeigen aktualisieren auf und führen der Reihe nach alle Aktionen aus.


    Quelle: WoltLab Suite 5.2 Veröffentlichung - Neuigkeiten und Hinweise - WoltLab®


    Datum: 29. Dezember 2019

    Uhrzeit: 21:34

    Die WoltLab Suite 5.2 ist der nächste Meilenstein in der Geschichte der Community- und Foren-Lösungen, probieren Sie unverbindlich den Nachfolger der überaus erfolgreichen WoltLab Suite 3 aus.


    Systemvoraussetzungen

    Für die Installation und Nutzung von WoltLab Suite 5.2 müssen die folgenden Voraussetzungen erfüllt sein:

    • Webserver mit PHP 7.0.22 oder neuer (PHP 7.4+ empfohlen)
    • MySQL 5.5.35 (oder neuer) / MariaDB 5.5.47 (oder neuer) / MariaDB 10.0.22 (oder neuer)
    • 20 MB Festplattenspeicher
    • Aktueller Webbrowser (Chrome 76+, Firefox 68+, Safari 12+, Microsoft Edge 44+ [EdgeHTML 18+])

    Installationsanleitung

    1. Laden Sie das Installations-Archiv auf Ihren Computer herunter.
    2. Entpacken Sie das Archiv.
    3. Laden Sie die Dateien install.php, test.php und WCFSetup.tar.gz auf Ihren Webserver hoch.
    4. Starten Sie die Installation, indem Sie die Datei test.php in Ihrem Webbrowser aufrufen.

    Aktualisierung von früheren Versionen

    Ein Upgrade wird von der WoltLab Suite 3.1.11 oder neuer unterstützt, für die Durchführung muss der Paket-Server http://update.woltlab.com/2019/ hinzugefügt werden. Wir weisen ausdrücklich darauf hin, dass es sich um eine Testversion handelt und ein erfolgreiches Upgrade nicht garantiert wird. Vor dem Upgrade raten wir dringend, ein vollständiges Backup der Installation anzufertigen. Die Durchführung des Upgrades erfolgt auf eigene Verantwortung!

    Nutzung & Support

    Es handelt sich um eine Testversion, die nicht für den produktiven Einsatz gedacht ist. Die Nutzung in einer Produktivumgebung erfolgt auf eigene Gefahr. Ein Update von WoltLab Suite 5.2 RC 2 auf zukünftige Versionen wird garantiert. Die Nutzungsdauer der Betaversion ist auf den 06. Feburar 2020 begrenzt, danach ist eine weitere Nutzung nur mit einer gültigen Lizenz gestattet.


    Fragen und Anregungen zu der neuen Version können direkt hier im Forum hinterlassen werden; Im Falle von Probleme oder Unstimmigkeiten bitten wir um eine kurze Rückmeldung im entsprechenden Bereich, damit wir uns dessen annehmen können.

    Anpassung der Versionsnummern

    Die Forum App nutzte aus historischen Gründen eine höhere Versionsnummer, wodurch es zu einigen Unklarheiten kam. Ab dieser Version laufen alle Produkte unter der einheitlichen Versionsnummer 5.2.

    Kompatibilität mit PHP 7.4

    Diese Version ist mit PHP 7.4 vollständig kompatibel.



    Download WoltLab Suite Forum 5.2 RC 2

    Download WoltLab Suite Blog 5.2 RC 2

    Download WoltLab Suite Calendar 5.2 RC 2

    Download WoltLab Suite Gallery 5.2 RC 2

    Download WoltLab Suite Filebase 5.2 RC 2


    Quelle: WoltLab Suite 5.2 RC 2 Download - Neuigkeiten und Hinweise - WoltLab®


    Datum: 20. Dezember 2019

    Uhrzeit: 19:19

    In den vergangenen Jahren wurden wir verstärkt von Kunden auf die Verfügbarkeit einer gemanagten Lösung für den Forenbetrieb angesprochen. Wir möchten diesen Kunden eine neue Alternative anbieten, bei der wir alle Aufgaben – angefangen vom Betrieb der technischen Infrastruktur bis hin zur regelmäßigen Pflege der Software – übernehmen. Selbstverständlich bieten wir auch weiterhin die Software zum eigenverantwortlichen Betrieb an, beachten Sie hierzu bitte unsere Ankündigung zu den neuen Mietlizenzen.

    Die WoltLab Cloud

    Mit unserem Managed Hosting-Angebot „WoltLab Cloud“ bieten wir eine umfassende Lösung für den Betrieb der WoltLab Suite. Wir übernehmen den gesamten technischen Betrieb, angefangen von der Installation über die kontinuierliche Aktualisierung der Software bis hin zu täglichen Datensicherungen. Alle WoltLab Suite Apps stehen unbeschränkt zur Verfügung und durch den konsequenten Einsatz von Elasticsearch profitieren Sie ohne Aufpreis von einer Suchfunktion auf Enterprise-Niveau.


    Die WoltLab Cloud wird innerhalb des 1. Quartal 2020 eingeführt.

    Die Stärken der WoltLab Cloud

    Wir haben uns von Anfang an das Ziel gesetzt, eine robuste und zuverlässige Plattform zu entwickeln, die in der Lage ist, einen stabilen Betrieb und eine durchgehend hohe Geschwindigkeit zu gewährleisten.


    Die wichtigsten Merkmale der WoltLab Cloud:

    • Alle WoltLab Suite Apps sind enthalten.
      • Inklusive Elasticsearch zur präzisen und schnellen Bearbeitung von Suchanfragen.
    • Vollständige technische Betreuung der Installation.
      • Wir übernehmen die Installation und regelmäßige Aktualisierung der Software.
      • Die täglichen Datensicherungen werden verschlüsselt auf einem separaten Server abgelegt.
      • Robuster DDoS-Schutz auf Netzwerkebene durch unseren Partner Voxility.
    • Installation von Stilen und Erweiterungen aus dem WoltLab Plugin-Store.
    • Optimierte und leistungsstarke Server-Infrastruktur.
      • Alle Daten werden zu 100% auf Enterprise-SSDs gespeichert.
      • Moderne und nach unseren Anforderungen zusammengestellte Server von Hewlett Packard Enterprise mit skalierbaren Intel Xeon Gold-Prozessoren der 2. Generation.
      • Geprüftes Tier 3+-Rechenzentrum in Frankfurt am Main.
    • Vollständige SSL/TLS-Verschlüsselung mit Zertifikaten von Let’s Encrypt.
    • Die Aufschaltung einer eigenen Domain ist ohne Zusatzkosten möglich.
    • Datenschutzkonformer Betrieb gemäß DSGVO
      • Vollständige Speicherung aller Daten innerhalb Deutschlands.
      • Datenübertragung durchgängig über SSL/TLS-verschlüsselte Verbindungen.
      • Auftragsverarbeitungsvertrag (AVV)
      • Umfassende technische und organisatorische Maßnahmen zum Schutz Ihrer Daten gemäß Art. 32 DSGVO.

    Standardtarife

    Für uns war es besonders wichtig, dass es keine Tarife 2. Klasse gibt und alle wichtigen Kernmerkmale uneingeschränkt zur Verfügung stehen: Alle Apps der WoltLab Suite, eine professionelle und präzise Suche auf Basis von Elasticsearch, und eine zu jedem Zeitpunkt hohe Geschwindigkeit der Seite.


    Die Standardtarife unterscheiden sich insbesondere durch den verfügbaren Speicherplatz sowie die zugesicherte Menge an Seitenaufrufen, die durch PHP verarbeitet werden. Der Speicherplatz berechnet sich durch die Summe des Speicherbedarfs der Dateien sowie der Datenbank, die täglichen Datensicherungen werden nicht einberechnet.


    Wir behalten uns Änderungen der vorgestellten Konditionen vor.


    StandardAdvancedProfessionalBusiness

    Speicherplatz

    10.000 MB

    25.000 MB

    50.000 MB

    100.000 MB

    PHP-Seitenaufrufe (pro Monat)

    200.000

    500.000

    1.000.000

    2.000.000

    Alle WoltLab Suite Apps

    Inklusive

    Inklusive

    Inklusive

    Inklusive

    TLS-Zertifikat

    Inklusive

    Inklusive

    Inklusive

    Inklusive

    Robuster DDoS-Schutz

    Inklusive

    Inklusive

    Inklusive

    Inklusive

    Suche mit Elasticsearch

    Inklusive

    Inklusive

    Inklusive

    Inklusive

    Branding Free

    Nein

    Nein

    Nein

    Inklusive

    Migration / Datenimport

    Optional

    Optional

    Optional

    Optional

    Design Service

    Nein

    Nein

    Optional

    Optional

    Single Sign-On

    Nein

    Nein

    Nein

    Optional

    Preis pro Monat

    EUR 29,95

    EUR 44,95

    EUR 69,95

    EUR 149,95


    Alle Preise verstehen sich inklusive 19% Mehrwertsteuer.

    Individuelle Pakete

    Für Kunden mit besonderen Anforderungen bieten wir individuell zugeschnittene Pakete an, die über das Angebot unserer Standardtarife hinausgehen. Gerne besprechen wir die Einzelheiten und unterbreiten Ihnen unverbindlich ein individuelles Angebot. Darüber hinaus besteht in diesem Rahmen auch die Möglichkeit zum Einsatz individueller Plugins, nachdem wir diese einem Audit unterzogen haben, um die Sicherheit und Stabilität der Installation weiterhin bestmöglich gewährleisten zu können.

    Wissenswertes zur WoltLab Cloud

    1. Können die Daten aus einem bestehenden Forum übernommen werden?

    Wir unterstützen den Import aus vielen verschiedenen Foren-Lösungen, selbstverständlich erarbeiten wir auch Lösungen für individuelle Systeme, sprechen Sie uns dazu einfach an und wir erstellen Ihnen ein unverbindliches Angebot.

    2. Können Plugins oder Stile installiert werden?

    Ja, Sie können fast alle Plugins bzw. Stile aus dem Plugin-Store direkt über die Administrationsoberfläche installieren, kostenpflichtige Einträge müssen zuvor erworben werden und sind nicht inklusive. Eigene Stile können über den Stil-Import installiert werden und sind nicht auf die Angebote des Plugin-Store beschränkt. Installierbare Pakete aus Drittquellen können aus Sicherheits- und Stabilitätsgründen nicht installiert werden.

    3. Was passiert, wenn die Limits überschritten werden?

    Eine Überschreitung hat keine direkten Folgen, Ihre Seite bleibt wie gewohnt für Sie und Ihre Besucher erreichbar. Sollten Sie die vereinbarten Ressourcen über einen längeren Zeitraum überschreiten, werden wir Sie kontaktieren, um gemeinsam eine Lösung zu finden.

    4. Wann ist eine Kündigung möglich und was passiert mit den Daten?

    Die angebotenen Standardpakete sind monatlich kündbar, wir stellen Ihnen bis zu 2 Monate nach der Kündigung eine vollständige Kopie Ihrer Daten zur Verfügung. Ein eigenverantwortlicher Weiterbetrieb der Software ist mit den passenden Lizenzen möglich.


    Quelle: Managed Hosting – Vorstellung der WoltLab Cloud - Neuigkeiten und Hinweise - WoltLab®


    Datum: 16. Dezember 2019

    Uhrzeit: 10:59

    Die WoltLab Suite 5.2 ist der nächste Meilenstein in der Geschichte der Community- und Foren-Lösungen, probieren Sie unverbindlich den Nachfolger der überaus erfolgreichen WoltLab Suite 3 aus.


    Systemvoraussetzungen

    Für die Installation und Nutzung von WoltLab Suite 5.2 müssen die folgenden Voraussetzungen erfüllt sein:

    • Webserver mit PHP 7.0.22 oder neuer (PHP 7.4+ empfohlen)
    • MySQL 5.5.35 (oder neuer) / MariaDB 5.5.47 (oder neuer) / MariaDB 10.0.22 (oder neuer)
    • 20 MB Festplattenspeicher
    • Aktueller Webbrowser (Chrome 76+, Firefox 68+, Safari 12+, Microsoft Edge 44+ [EdgeHTML 18+])

    Installationsanleitung

    1. Laden Sie das Installations-Archiv auf Ihren Computer herunter.
    2. Entpacken Sie das Archiv.
    3. Laden Sie die Dateien install.php, test.php und WCFSetup.tar.gz auf Ihren Webserver hoch.
    4. Starten Sie die Installation, indem Sie die Datei test.php in Ihrem Webbrowser aufrufen.

    Aktualisierung von früheren Versionen

    Ein Upgrade wird von der WoltLab Suite 3.1.11 oder neuer unterstützt, für die Durchführung muss der Paket-Server http://update.woltlab.com/2019/ hinzugefügt werden. Wir weisen ausdrücklich darauf hin, dass es sich um eine Testversion handelt und ein erfolgreiches Upgrade nicht garantiert wird. Vor dem Upgrade raten wir dringend, ein vollständiges Backup der Installation anzufertigen. Die Durchführung des Upgrades erfolgt auf eigene Verantwortung!

    Nutzung & Support

    Es handelt sich um eine Testversion, die nicht für den produktiven Einsatz gedacht ist. Die Nutzung in einer Produktivumgebung erfolgt auf eigene Gefahr. Ein Update von WoltLab Suite 5.2 RC 1 auf zukünftige Versionen wird garantiert. Die Nutzungsdauer der Betaversion ist auf den 06. Feburar 2020 begrenzt, danach ist eine weitere Nutzung nur mit einer gültigen Lizenz gestattet.


    Fragen und Anregungen zu der neuen Version können direkt hier im Forum hinterlassen werden; Im Falle von Probleme oder Unstimmigkeiten bitten wir um eine kurze Rückmeldung im entsprechenden Bereich, damit wir uns dessen annehmen können.

    Anpassung der Versionsnummern

    Die Forum App nutzte aus historischen Gründen eine höhere Versionsnummer, wodurch es zu einigen Unklarheiten kam. Ab dieser Version laufen alle Produkte unter der einheitlichen Versionsnummer 5.2.

    Kompatibilität mit PHP 7.4

    Diese Version ist mit PHP 7.4 vollständig kompatibel.



    Download WoltLab Suite Forum 5.2 RC 1

    Download WoltLab Suite Blog 5.2 RC 1

    Download WoltLab Suite Calendar 5.2 RC 1

    Download WoltLab Suite Gallery 5.2 RC 1

    Download WoltLab Suite Filebase 5.2 RC 1


    Quelle: WoltLab Suite 5.2 RC 1 Download - Neuigkeiten und Hinweise - WoltLab®


    Datum: 12. Dezember 2019

    Uhrzeit: 17:49

    Die WoltLab Suite 5.2 ist der nächste Meilenstein in der Geschichte der Community- und Foren-Lösungen, probieren Sie unverbindlich den Nachfolger der überaus erfolgreichen WoltLab Suite 3 aus.


    Systemvoraussetzungen

    Für die Installation und Nutzung von WoltLab Suite 5.2 müssen die folgenden Voraussetzungen erfüllt sein:

    • Webserver mit PHP 7.0.22 oder neuer (PHP 7.3+ empfohlen)
    • MySQL 5.5.35 (oder neuer) / MariaDB 5.5.47 (oder neuer) / MariaDB 10.0.22 (oder neuer)
    • 20 MB Festplattenspeicher
    • Aktueller Webbrowser (Chrome 76+, Firefox 68+, Safari 12+, Microsoft Edge 44+ [EdgeHTML 18+])

    Installationsanleitung

    1. Laden Sie das Installations-Archiv auf Ihren Computer herunter.
    2. Entpacken Sie das Archiv.
    3. Laden Sie die Dateien install.php, test.php und WCFSetup.tar.gz auf Ihren Webserver hoch.
    4. Starten Sie die Installation, indem Sie die Datei test.php in Ihrem Webbrowser aufrufen.

    Aktualisierung von früheren Versionen

    Diese Beta-Version unterstützt keine Aktualisierung von früheren Versionen von WoltLab Suite 3.x, die Update-Funktionalität wird erst mit nachfolgenden Version 5.2.0 RC 1 ermöglicht.

    Nutzung & Support

    Es handelt sich um eine Testversion, die nicht für den produktiven Einsatz gedacht ist. Die Nutzung in einer Produktivumgebung erfolgt auf eigene Gefahr. Ein Update von WoltLab Suite 5.2 Beta 4 auf zukünftige Versionen wird nicht garantiert. Die Nutzungsdauer der Betaversion ist auf den 06. Januar 2020 begrenzt, danach ist eine weitere Nutzung nur mit einer gültigen Lizenz gestattet.


    Fragen und Anregungen zu der neuen Version können direkt hier im Forum hinterlassen werden; Im Falle von Probleme oder Unstimmigkeiten bitten wir um eine kurze Rückmeldung im entsprechenden Bereich, damit wir uns dessen annehmen können.

    Anpassung der Versionsnummern

    Die Forum App nutzte aus historischen Gründen eine höhere Versionsnummer, wodurch es zu einigen Unklarheiten kam. Ab dieser Version laufen alle Produkte unter der einheitlichen Versionsnummer 5.2.

    Kompatibilität mit PHP 7.4

    Diese Version unterstützt erstmalig PHP 7.4, sollte es zu weiteren Problemen mit PHP 7.4 kommen, bitten wir um eine Rückmeldung im Forum. Updates für die WoltLab Suite 3.x-Versionen werden demnächst freigegeben, so dass auch diese Versionen mit PHP 7.4 kompatibel sind.



    Download WoltLab Suite Forum 5.2 Beta 4

    Download WoltLab Suite Blog 5.2 Beta 4

    Download WoltLab Suite Calendar 5.2 Beta 4

    Download WoltLab Suite Gallery 5.2 Beta 4

    Download WoltLab Suite Filebase 5.2 Beta 4


    Quelle: WoltLab Suite 5.2 Beta 4 Download - Neuigkeiten und Hinweise - WoltLab®


    Datum: 1. Dezember 2019

    Uhrzeit: 17:39

    Die Veröffentlichung der neue Version WoltLab Suite 5.2 rückt in greifbare Nähe und wir möchten vorab über die neue Lizenzart informieren. Das bisher verwendete Konzept der Kauflizenz, mit Beschränkung auf die aktuellste Version zum Kaufzeitpunkt, wird durch eine Mietlizenz abgelöst.


    Die neue Mietlizenz läuft ein Jahr, innerhalb dieses Zeitraums erhalten Sie automatisch Zugriff auf jede neue Version, die veröffentlicht wird, sowie Hilfestellung und technische Unterstützung im Rahmen unseres Ticket-Supports. Mit Ablauf der Laufzeit endet die Mietlizenz automatisch und kann optional um jeweils ein weiteres Jahr verlängert werden.


    Sollten Sie sich gegen eine Verlängerung der Mietlizenz entscheiden, behalten Sie dennoch das Recht, die zuletzt in Ihrer Lizenz verfügbare Version weiterhin zu verwenden. Ihre Installation bleibt somit ununterbrochen lauffähig, auch wenn Sie die Mietlizenz nicht verlängern. Der Zugang zu neuen Versionen sowie dem Ticket-Support ist jedoch aktiven Lizenzen vorbehalten.


    Technische und rechtliche Änderungen haben in den letzten Jahren zeitnahe und teilweise umfangreiche Anpassungen erfordert, beispielsweise die DSGVO, deren Umsetzung im Rahmen eines Bugfix-Releases den Ansprüchen an Stabilität entgegensteht. Mit der WoltLab Suite 5.2 passen wir unsere Strategie für die Weiterentwicklung der Software an: Neue Versionen erscheinen in kürzeren Abständen in Verbindung mit einem kompakteren und übersichtlicheren Funktionsumfang. Neue Features und Verbesserungen bestehender Funktionen stehen dadurch deutlich schneller zur Verfügung, durch den starken Fokus auf die Abwärtskompatibilität werden Upgrades so einfach und problemlos wie möglich gestaltet.


    Die unten aufgeführten Preise treten mit der Veröffentlichung der endgültigen Version von WoltLab Suite 5.2, voraussichtlich im Dezember 2019, in Kraft.

    Preise

    Diese Preise gelten für neue Mietlizenzen ab WoltLab Suite 5.2.


    App für WoltLab SuitePreis
    WoltLab Suite Forum
    Neue LizenzEUR 99,99
    Update von der Version 4.x/5.x oder
    Abgelaufene Mietlizenz für WoltLab Suite Forum
    EUR 49,99
    --
    WoltLab Suite Blog
    Neue LizenzEUR 59,99
    Update von der Version 2.x/3.x oder
    Abgelaufene Mietlizenz für WoltLab Suite Blog
    EUR 29,99
    --
    WoltLab Suite Calender
    Neue LizenzEUR 59,99
    Update von der Version 2.x/3.x oder
    Abgelaufene Mietlizenz für WoltLab Suite Calendar
    EUR 29,99
    --
    WoltLab Suite Filebase
    Neue LizenzEUR 59,99
    Update von der Version 2.x/3.x oder
    Abgelaufene Mietlizenz für WoltLab Suite Filebase
    EUR 29,99
    --
    WoltLab Suite Gallery
    Neue LizenzEUR 59,99
    Update von der Version 2.x/3.x oder
    Abgelaufene Mietlizenz für WoltLab Suite Gallery
    EUR 29,99



    ErweiterungPreis
    Branding Free
    Neue LizenzEUR 249,99
    Update von einer früheren Versionkostenlos (*)
    --
    LDAP-Anbindung
    Neue LizenzEUR 99,99
    Update von einer früheren Versionkostenlos (*)
    --
    elasticsearch-Integration
    Neue LizenzEUR 99,99
    Update von einer früheren Versionkostenlos (*)


    (*) Bei den Erweiterungen handelt es sich um Einmalzahlungen, die automatisch auch für die nachfolgenden Versionen gelten. Ein Update muss nicht separat erworben werden, die Lizenz wird automatisch um den Zugang zu neuen Versionen erweitert.


    Alle Preise verstehen sich inklusive 19% Mehrwertsteuer.

    Wissenswertes zur Mietlizenz

    1. Was passiert mit der Installation, wenn die Mietlizenz ausläuft?

    Ihre Installation bleibt unverändert lauffähig, Sie können diese weiterhin ohne Einschränkungen nutzen und Sie erhalten weiterhin Sicherheitsupdates für diese Version.


    Der Zugang zu neuen Versionen und dem Ticket-Support setzt jedoch eine aktive Mietlizenz voraus, Sie können Ihre abgelaufene Mietlizenz bei Bedarf für ein weiteres Jahr verlängern.

    2. Wie lange ist die Mietlizenz gültig? Handelt es sich um ein Abonnement?

    Die Mietlizenz läuft für ein Jahr und kann optional um jeweils ein weiteres Jahr verlängert werden, mit Ablauf des Mietzeitraums läuft die Lizenz automatisch aus. Nur Sie entscheiden, ob Sie die Mietlizenz verlängern möchten, ein Abonnement besteht nicht.

    3. Was passiert mit Bestandslizenzen und der alten Platinum-Lizenz?

    Für alte Lizenzen bis einschließlich der WoltLab Suite 3.1 ergeben sich keine Änderungen, es gelten weiterhin die zum Kauf gültigen Lizenzbestimmungen. Die Konditionen der neuen Mietlizenzen gelten nur für neue Lizenzen bzw. Lizenzen, die um den Zugang zur neuen Version erweitert wurden.


    Die Platinum-Lizenzen bleiben unverändert gültig und erhalten automatisch Zugang zur neuen Version WoltLab Suite Forum 5.2.


    Quelle: Verkaufsstart und Lizenzpreise von WoltLab Suite 5.2 - Neuigkeiten und Hinweise - WoltLab®


    Datum: 21. November 2019

    Uhrzeit: 19:44

    Die WoltLab Suite 5.2 ist der nächste Meilenstein in der Geschichte der Community- und Foren-Lösungen, probieren Sie unverbindlich den Nachfolger der überaus erfolgreichen WoltLab Suite 3 aus.


    Systemvoraussetzungen

    Für die Installation und Nutzung von WoltLab Suite 5.2 müssen die folgenden Voraussetzungen erfüllt sein:

    • Webserver mit PHP 7.0.22 oder neuer (PHP 7.3+ empfohlen)
    • MySQL 5.5.35 (oder neuer) / MariaDB 5.5.47 (oder neuer) / MariaDB 10.0.22 (oder neuer)
    • 20 MB Festplattenspeicher
    • Aktueller Webbrowser (Chrome 76+, Firefox 68+, Safari 12+, Microsoft Edge 44+ [EdgeHTML 18+])

    Installationsanleitung

    1. Laden Sie das Installations-Archiv auf Ihren Computer herunter.
    2. Entpacken Sie das Archiv.
    3. Laden Sie die Dateien install.php, test.php und WCFSetup.tar.gz auf Ihren Webserver hoch.
    4. Starten Sie die Installation, indem Sie die Datei test.php in Ihrem Webbrowser aufrufen.

    Aktualisierung von früheren Versionen

    Diese Beta-Version unterstützt keine Aktualisierung von früheren Versionen von WoltLab Suite 3.x, die Update-Funktionalität wird erst mit nachfolgenden Versionen ermöglicht.

    Nutzung & Support

    Es handelt sich um eine Testversion, die nicht für den produktiven Einsatz gedacht ist. Die Nutzung in einer Produktivumgebung erfolgt auf eigene Gefahr. Ein Update von WoltLab Suite 5.2 Beta 3 auf zukünftige Versionen wird nicht garantiert. Die Nutzungsdauer der Betaversion ist auf den 06. Januar 2020 begrenzt, danach ist eine weitere Nutzung nur mit einer gültigen Lizenz gestattet.


    Fragen und Anregungen zu der neuen Version können direkt hier im Forum hinterlassen werden; Im Falle von Probleme oder Unstimmigkeiten bitten wir um eine kurze Rückmeldung im entsprechenden Bereich, damit wir uns dessen annehmen können.

    Anpassung der Versionsnummern

    Die Forum App nutzte aus historischen Gründen eine höhere Versionsnummer, wodurch es zu einigen Unklarheiten kam. Ab dieser Version laufen alle Produkte unter der einheitlichen Versionsnummer 5.2.



    Download WoltLab Suite Forum 5.2 Beta 3

    Download WoltLab Suite Blog 5.2 Beta 3

    Download WoltLab Suite Calendar 5.2 Beta 3

    Download WoltLab Suite Gallery 5.2 Beta 3

    Download WoltLab Suite Filebase 5.2 Beta 3


    Quelle: WoltLab Suite 5.2 Beta 3 Download - Neuigkeiten und Hinweise - WoltLab®


    Datum: 15. November 2019

    Uhrzeit: 18:14